TCAX程序及py特效脚本兼容性说明 - 相关文档 - TCAX 字幕特效制作工具官方论坛 | ASS | TCAS | Python | Aegisub | Lua - Powered by Discuz!

TCAX 字幕特效制作工具官方论坛 | ASS | TCAS | Python | Aegisub | Lua

 找回密码
 加入社区
查看: 3644|回复: 1

TCAX程序及py特效脚本兼容性说明 [复制链接]

Administrator

TCAX Dev.

Rank: 7Rank: 7Rank: 7

发表于 2012-2-24 19:32:05 |显示全部楼层
TCAX在升级的过程中会尽量保持向后兼容性(Backward compatibility), 即, 新版本的TCAX会兼容在旧版本TCAX下编写的py特效脚本. 但需要注意的是, 新版本TCAX下编写的py特效脚本未必能够被旧版本的TCAX执行. 所以, 建议一直使用最新的TCAX程序.

如果遇到论坛上提供的脚本/例子不能被正确执行, 请先升级到最新版的TCAX, 再做试验.

不同版本的TCAX可以共存, 只要保存在不同的文件夹下即可, 可以用打开方式选择具体的某一版本. 也可以执行某一版本下的assoc.exe程序, 建立文件关联.

对于程序升级, 不建议采用覆盖的方式, 而是采用先删除旧版本, 再升级. 所以自己编写的特效工程, 脚本等, 不要放在TCAX程序根目录下, 而是另行建立目录.

如果之后的升级带来了任何脚本兼容性问题, 会在本帖进行说明.



Rank: 4

发表于 2018-1-16 15:48:50 |显示全部楼层
谢谢楼主分享
您需要登录后才可以回帖 登录 | 加入社区

GitHub|TCAX 主页

GMT+8, 2018-8-15 08:00

Powered by Discuz! X2

© 2001-2011 Comsenz Inc.

回顶部
RealH